Unverified Commit a9ab5a0a authored by Laurent Modolo's avatar Laurent Modolo
Browse files

umitools: fix python version

parent 0fc97384
......@@ -37,15 +37,9 @@ source ../build_env.sh
module load Python/3.6.1
UMITOOLS_VERSION=0.3.4
UMITOOLS_ROOT=/Xnfs/lbmcdb/common/modules/apps/UMITOOLS/${UMITOOLS_VERSION}
mkdir -p ${UMITOOLS_VERSION}/lib/python3.6/dist-packages/
PYTHONPATH=${UMITOOLS_ROOT}lib/python3.6/dist-packages/:$PYTHONPATH
UMITOOLS_ROOT=/Xnfs/lbmcdb/common/modules/apps/umitools/${UMITOOLS_VERSION}
mkdir -p ${UMITOOLS_VERSION}/lib/python3.5/dist-packages/
PYTHONPATH=${UMITOOLS_ROOT}lib/python3.5/dist-packages/:$PYTHONPATH
git clone https://github.com/weng-lab/umitools.git
cd umitools
python setup.py install --single-version-externally-managed --prefix ${UMITOOLS_ROOT} --record markupsafe_install.txt
cd ..
rm -Rf markupsafe
pip install umitools==${UMITOOLS_VERSION} --prefix ${UMITOOLS_ROOT}
mv bin lib ${UMITOOLS_VERSION}/
rm -Rf UMITOOLS
......@@ -39,6 +39,6 @@ conflict("cutadapt")
conflict("Python/2.7.13")
load("Python/3.6.1")
prereq_any("Python/3.6.1")
prepend_path{"PYTHONPATH","/Xnfs/lbmcdb/common/modules/apps/umitools/0.3.4/lib/python3.6/site-packages/",delim=":",priority="0"}
prepend_path{"PYTHONPATH","/Xnfs/lbmcdb/common/modules/apps/umitools/0.3.4/lib/python3.5/site-packages/",delim=":",priority="0"}
prepend_path{"PATH","/Xnfs/lbmcdb/common/modules/apps/umitools/0.3.4/bin",delim=":",priority="0"}
setenv("HTSEQ_PATH","/Xnfs/lbmcdb/common/modules/apps/umitools/0.3.4/bin")
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment